Oracle MVA

Tales from a Jack of all trades

Archive for the ‘OUI’ Category

OUI crashing

leave a comment »

Today I had some fun trying to install CRS on OEL4 in OracleVM. After setting up the system for the installation (ssh, kernel settings, RPM’s etc) I tried to start the installer (OUI). As soon as I saw the first screen and hit the next button, OUI crashed:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0x0000002a959248a4, pid=11755, tid=182894172512
#
# Java VM: Java HotSpot(TM) 64-Bit Server VM (1.5.0_11-b03 mixed mode)
# Problematic frame:
# V  [libjvm.so+0x3a98a4]
#
# An error report file with more information is saved as hs_err_pid11755.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp

The OUI did not have any logging that pointed me in the correct direction, nog even after adding the -logLevel trace -debug /-J-DTRACING.ENABLED=TRUE -J-DTRACING.LEVEL=2/ options. Some extensive searching pointed me towards the oraInst.loc. oraInst.loc is supposed to give references to the directory and group of the Oracle Inventory, but in my case the oraInst.loc looked like this:

$ cat /etc/oraInst.loc
inst_group=dba

the inventory_loc parameter is missing. Typo’s, missing or wrong information and wrong casing in the oraInst.loc apparently crash OUI !?

Since no other Oracle products are on the system, I could safely remove the file. Now OUI works like a charm. What’s left is finding out where this file came from. I suspect the base image that was used for installing OEL4 (provisioned from OMS)

Written by Jacco H. Landlust

September 2, 2009 at 1:51 pm

Posted in OUI